1

Problems Installing Ruby 1.9.3 on OSX Lion 10.7.3

When I tried to install Ruby 1.9.3 via RVM I came across the following issues:

Error running ' ./configure --prefix=/Users/Jason/.rvm/rubies/ruby-1.9.3-p0 --enable-shared --disable-install-doc --with-gcc=clang --with-libyaml --with-opt-dir=/Users/Jason/.rvm/usr ', please read /Users/Jason/.rvm/log/ruby-1.9.3-p0/configure.log
There has been an error while running configure. Halting the installation.

I got around the first error by installing the osx-gcc-installer from here.

I then tried to install ruby 1.9.3using the following command:

rvm install 1.9.3 --with-gcc=clang

I then received the second error:

Error running 'make ', please read /Users/Jason/.rvm/log/ruby-1.9.3-p0/make.log
There has been an error while running make. Halting the installation.

I managed to resolve it by installing rvm via the normal command:

rvm install 1.9.3

I then passed rvm with the command to set 1.9.3 as default:

rvm default 1.9.3

Below is the output of typing ruby -v in my terminal after following this process:

athos:~ Jason$ ruby -v
ruby 1.8.7 (2010-01-10 patchlevel 249) [universal-darwin11.0]
athos:~ Jason$ rvm default 1.9.3
athos:~ Jason$ ruby -v
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.3.0]

Crisis resolved!

Jason Edwards

  • nice articles thanks for sharing.